User Tag List

+ Reply to Thread
Results 1 to 3 of 3

Thread: Twin choke idle issue

  1. #1
    Bodger

    Join Date
    Jul 2019
    Location
    Peterborough
    Age
    44
    Posts
    71
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Twin choke idle issue

    Hi all, having a bit of a do with my mk2 1600 Ghia auto crossflow carb. Its a twin choke 32/36 and was having idle and a flat spot issue when I bought it. I took the carb off today and stripped it all down (jets all out) and blew all the jets through and the orifices with carb cleaner. Replaced both diaphragms and used a new carb top and base gasket and securely tightened it down. It starts ok and revs out clean,no more flat spot anymore,but will idle for a few seconds then drop down until it nearly stalls then the idle comes back. Will do this every few seconds on idle. The only other thing I changed was a new float valve,but it revs out clean. Any ideas?

  2. #2
    Pole Position Decade Plus User Miniliteman's Avatar

    Join Date
    Feb 2004
    Location
    the Netherlands
    Posts
    4,391
    Thanks
    19
    Thanked 461 Times in 429 Posts

    Re: Twin choke idle issue

    Check all vacuum hoses from inlet manifold to carb and brake booster and PCV for leaks or cracks.

  3. #3
    Bodger

    Join Date
    Jul 2019
    Location
    Peterborough
    Age
    44
    Posts
    71
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Re: Twin choke idle issue

    Thanks, I will check those, although i did fit new vacuum pipes and made sure they were clear. I did change the float valve for the new one in the kit and set the float level. Just wondering if this may be causing flooding on idle? Might try the old float valve again.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts