User Tag List

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 41 to 44 of 44

Thread: Transit MK2 Zetec 2.0

  1. #41
    Tyre Kicker

    Join Date
    Jun 2006
    Location
    Finland
    Age
    40
    Posts
    27
    Thanks
    6
    Thanked 1 Time in 1 Post

    Re: Transit MK2 Zetec 2.0

    Update as things have gone forward again:

    Rest of the exhaust is done


    Been hiding and rerouting those cables from engine bay. Ecu, relays and fuseboxes are above the glovebox now.
    Intake air pipe is just temporary until i get the one i ordered last week.


    Then some delays to the project:
    Removed side rear windows and uh oh its welding time soon again... Probably going to weld them close, looks better that way imo.



    Some coolant leak and unburned fuel issues to be solved:


    I actually drove the thing around my yard today, lots of black smoke out of exhaust when accelerating though. Parked it and swapped silvertop injectors and fuelrail and tried starting it again and it didnt even turn the engine anymore.
    Further inspecting things, i noticed after taking spark plugs out that cyl. 2 is full of unburnt fuel. Emptied that and it started again easily, drove it back in garage fast and:


    Going to try again tomorrow with new leads and coil after things have dried up a bit.
    Last edited by Works; 14-02-2020 at 18:27.

  2. #42
    I support TS Decade Plus User
    Turbosport Subscriber
    alladdin's Avatar

    My 1st Project
    My 2nd Project
    Join Date
    May 2005
    Location
    s.wales
    Age
    56
    Posts
    9,521
    Thanks
    111
    Thanked 380 Times in 375 Posts

    Re: Transit MK2 Zetec 2.0

    injector stuck open ? or shorted power on all the time ?

  3. #43
    Tyre Kicker

    Join Date
    Jun 2006
    Location
    Finland
    Age
    40
    Posts
    27
    Thanks
    6
    Thanked 1 Time in 1 Post

    Re: Transit MK2 Zetec 2.0

    Quote Originally Posted by alladdin View Post
    injector stuck open ? or shorted power on all the time ?
    Probably injector seal was not on its place properly, as it dumped everything in cyl 2. Got them to hold, but theres still issues.

    The 1.8 escort injector no 2 is probably broken or something, as theres alot of difference in output compared to rest:
    Few seconds of cranking and results (from left injector 1 ->)


    Then galaxy injectors, which seem to be alot better:


    Not sure if its smoking because its still burning fuel from exhaust as its still dripping from silencer, or is its still getting too much juice, but its certainly running better now, but still not perfect by any means.
    Video of it running:
    https://vimeo.com/391650871

    mqdefault.jpg


    Going to try with the 1.8 throttlebody+tps next, but if anyone has ideas im listening

  4. #44
    Tyre Kicker

    Join Date
    Jun 2006
    Location
    Finland
    Age
    40
    Posts
    27
    Thanks
    6
    Thanked 1 Time in 1 Post

    Re: Transit MK2 Zetec 2.0

    Took head off from the engine, as i was really starting to suspect a blown headgasket, but most likely it was not as i could not see any signs of coolant leakage anywhere.
    Tried to look for cracks aswell, but could not find any. I havent heard yet that these engines would be prone to crack heads? or are they, from where?
    Atleast the bores are in really good shape, hone marks still showing and no scratches/wear at all.

    Going to get the head straightened as its off. Swapping all new seals, timing belt waterpump etc. Thats it for going budget again




+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts